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Que:1 Describe the use of spelling and grammar features in MS Word. 

Ans: MS Word provides a feature to check spelling and grammar errors; it indicates 

spelling errors with a red wavy line and grammatical errors with a green wavy line. 

The newly added wavy underline in Word is blue, which indicates formatting 

inconsistencies. 

To start checking spelling and grammar in the entire file, simply press the function 

key F7 (Spelling and Grammar Checker) or Proceed with the steps given below: 

i. Click on the Review tab of Ribbon. 

ii. Click on Spelling or Spelling and Grammer option. 

A) If spelling errors are found in the document, a dialog box appears with 

the first misspelling found by the spelling checker.  

B) After deciding to resolve the misspelling (ignoring it, adding it to the 

dictionary, or replacing it), the program moves on to the next 

misspelling.  
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Que:2 Explain the use of the Page Setup option in MS Word. 

Ans: Page Setup allows us to change the structure and layout of pages in a 

document. The “Page Setup” group on the “Page Layout” tab contains buttons that 

allow us to change the page setup of a document. We can open the “Page Setup” 

dialog box by clicking on the dialog box launcher (located in the lower right corner) 

in the “Page Setup” group of the “Page Layout” tab. This dialog box has three tabs: 

Margins, Paper, and Layout. 

Margin:  

A margin is the space between the text and the edges of our document. By default, 

the margins of a new document are set to Normal, which means that it has one inch 

of space between the text and each edge. Based on our requirements, Word allows 

us to change the size of the margins of our document. 

Steps to change the Page Margins: 

1. Click the Margins tab in the Page Setup dialog box. 

2. Set the top, bottom, left, and right margins as needed. 

3. Click OK. 

Orientation:        

Page orientation refers to the direction in which the document is displayed/printed. 

Steps to change the Page Orientation: 

1. Click the Margins tab in the Page Setup dialog box. 

2. Set the page orientation to Portrait or Landscape as needed. 

3. Click OK. 

Page Size: 

We can set the page size of our document using this option. The page size can be 

LETTER SIZE, A4 and LEGAL SIZE etc. The default paper size in Microsoft Word is 8.5 

x 11 inches (LETTER SIZE). 

Steps to change Page Size:  

1. Click the Paper tab in the Page Setup dialog box. 

2. Select a page size from the drop-down list, for example: A4, Legal. 

3. Click OK. 
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Print Preview and Print Options  
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Que:3 Explain Print Preview and Print options in MS Word. 

Ans: Print Preview is a feature that allows us to see how our document will look 

when printed, before actually printing it. The steps to view a document using 

Print Preview are as follows: 

1. Click on the File tab. 

2. When we click on the Print (Ctrl + P) option, it automatically shows a 

preview of our document. 

3. Select the printing options like Copies, Page Range, Collate etc. 

4. Now, click on the Print button to get a hardcopy of the document. 
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Que:4 Explain the use of Formula bar of Excel. 

Ans: The Formula Bar is one of the most important components of MS Excel. The 

Formula Bar is located at the top of the Excel window and just below the Ribbon 

area. The Formula Bar has two parts, the left side shows the cell address, and the 

right side shows the data/formula of the currently selected cell as shown in the 

figure. 

The formula becomes active as soon as you type the equal sign in any cell or click 

anywhere inside the formula bar. The formula bar displays the formulas entered in 

the cell instead of the result. The formula bar can also be used to edit formulas or 

other data entered in the active cell by clicking in the formula bar. It can also be 

used to edit the ranges of data series that are selected in an Excel chart. 

Working with Formulas: 

Microsoft Excel is an electronic spreadsheet that automates calculations involved in 

school results, grading, and student fees, etc. A formula always begins with an “=” 

(equal) sign. Excel can perform mathematical calculations for us. 

Examples of Formulas are : 

=D15+D18+D21    

=A10/B15       

=(B16+C16)*1.07  

When creating formulas, we can type cell addresses or select cell addresses using 

the mouse.  
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Some Commonly used functions of Excel 

 

 

It calculates the sum of the values from cells A1 to C1 in cell D1 and shows 93 as a result. 

 

 

 

This will count the numbers in the range A1:C1 and display the result as 3. 

 

 

 

 

This will display the largest number in the range A1:C1, i.e. 56. 

 

 

 

This will display the smallest number in the range A1:C1, i.e. 12. 

 

 

 

This will display the average value of the numbers in the range A1:C1, i.e. 31. 
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Que:5 Explain some commonly used formulas in Excel. 

Ans: Some common functions used in Excel: 

SUM:  

The SUM function in Excel returns the sum of the supplied values. The SUM 

function adds up values. We can include values, cell references or ranges, or a 

combination of all three. 

Syntax: 

 =SUM (number1, [number2], [number3], ...) 

 

COUNT:   

The COUNT function counts the number of cells that contain numbers or counts 

the numbers in a list of arguments. 

Syntax: 

=COUNT (value1, [value2], ...) 

 

MAX:  

The MAX function in Excel returns the largest numeric value in a range of values. 

The MAX function ignores blank cells, logical values, true and false, and text values. 

Syntax: 

=MAX (number1, [number2], ...) 

 

MIN:  

The Excel Min function returns the smallest numeric value in a range of values. The 

Min function ignores blank cells, logical values, True and False, and text values. 

Syntax: 

=MIN (number1, [number2], ...) 

 

AVERAGE:  

The AVERAGE function in Excel returns the average of the values provided to the 

function. The AVERAGE function can handle up to 255 different arguments, which 

can include numbers, cell reference ranges, arrays, and constants. 

Syntax: 

=AVERAGE (number1, [number2], ...) 
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Que:6 Explain the use of Custom Filters in Excel 

Ans: Sometimes our worksheets contain a lot of data, and it becomes difficult to 

find the information quickly. Filters can be used to select specific data from our 

worksheets, allowing us to see only the information we need. 

i. Click the Data tab and then click the Filter command. A drop-down arrow will 

appear in the cell above each column. 

ii. Click the drop-down arrow for the column you want to filter. For example: 

Subject 

iii. Click on Custom Filter in the Filter menu. 

iv. The Custom AutoFilter dialog box will appear. 

v. Select the filter criteria and type its value (Example: Math) 

vi. The data will be filtered by the selected text filter, as shown in the image. 
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Output of Program 
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Que:7 Write a program in C language that determines whether a student has 

passed or failed based on the marks obtained by the student. Marks should be 

entered through the keyboard. 

Ans: 
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Output of Program 
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Que: 8 Write a program in C language to find the grade of a student which 

displays the grade of the student according to the following numbers: 

• If marks >= 80 then show Grade A 

• If marks >= 60 and < 80 then show Grade B 

• If marks >= 40 and < 60 then show Grade C 

• Otherwise show Grade D 

Ans: 
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Output of Program 
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Que: 9 Write a program in C language to print the names for the days of 

the week, Display the name of the day according to the day number input 

by the user. 

Ans: 
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Output of Program 
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Que:10 Write a program in C language to display natural numbers from 1 

to n using for loop. 

Ans: 
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Output of Program 
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Que:11 Write a program in C language to display EVEN numbers from 10 

to 1 using while loop. 

Ans: 
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Communication Media   

Twisted Pair Cable 

Optical Fibre 

Coaxial Cable 
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Que:12 Describe the different communication media used for networks. 

Ans: The term communication media refers to the medium through which data 

or information can be exchanged (communicated), such as telecommunications. 

Various types of transmission media are used to transfer data. These 

transmission media can be of two types: 

1. Guided Media: 

Guided media transmits data using cables that have a defined path. For example, 

copper wires, fiber optic cables, etc. 

• Twisted Pair Cable: A twisted pair cable consists of two separate insulated 

copper wires that are twisted together and run parallel to each other. The 

first wire is used to transfer data, and the second wire is used for grounding. 

These two insulated copper wires are twisted around each other to reduce 

crosstalk or electromagnetic induction between the wires. 

• Coaxial Cable: A coaxial cable is a two-conductor electrical cable that has a 

center conductor and an outer conductor, with an insulating spacer between 

the two. Coaxial cables are copper cables with better insulation than twisted 

pair cables, so that the transmitted signal can travel longer distances at 

higher speeds. 

• Optical fibre: An optical fibre cable consists of many optical fibres (a thin, 

flexible fibre with a core of glass) that are usually covered in plastic covers or 

shields. Optical cables are used to transfer digital data signals in the form of 

light over distances of hundreds of miles at a higher rate than electrical 

transmission cables. All optical cables use hair-like fibres made of transparent 

silicon. Each fibre is made up of three layers, starting from the inner layer: 

o Core which is made of high-quality silica glass or plastic. 

o Cladding made of high-quality silica glass or plastic. 

o External protective covering, called buffer. 

2. Unguided Media: 

Media that does not use any type of directed media or any guided media such 

as cables etc. is called unguided media. This type of communication is also often 

referred to as wireless communication. For example: 

• Infrared 

• Bluetooth 

• Wi-Fi 

• Radio waves 

• Microwaves 

• Satellites
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 Devices and Printers option in Control Panel 

 

Sharing Printer 
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Que:13 What is meant by printer sharing? How would you share a printer 

over a network? 

Ans: Printer sharing is the process of allowing multiple computers and devices 

connected to the same network to access one or more printers. Each node or 

device on the network can print to any shared printer and, to some extent, can 

change printer settings based on the permissions assigned to each user by the 

administrator. 

If the printer is connected to a computer that supports printer sharing, the 

computer can share the same printer with other computers on the same 

network. It does not matter whether the shared printer is old or new. 

 

Sharing Printer: 

• Open Devices and Printers from the Control Panel 

• Right-click the printer you want to share. Click Printer Properties and then 

select the Sharing Tab. 

• Click Sharing Printer. Under Share Name, select the shared name to identify 

the printer. Click OK. 
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Current Trends in Information Technology   

Wi-Fi Technology 

E-Commerce 

GPS Technology 

Android Technology 
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Que:14 Explain the Current Trends in IT. 

Ans: Information Technology has made unprecedented progress in the last few 

years. Therefore, we need to constantly keep an eye on the emerging trends and 

their implementation. The IT industry never stands still. It is a constantly changing 

field, with technologies, tools, software frameworks and numerous tools and 

endless ideas. 

The list of current trends in Information Technology can be endless. Here, we want 

to focus on just a few trends in Information Technology: 

1. WIFI Technology: Wi-Fi stands for Wireless Fidelity. It is a technology that 

uses radio waves for wireless high-speed internet and network 

connections. Wi-Fi is a network facility through which we can connect our 

computer, smartphone, laptop, or any other device to the internet without 

any wire. But its coverage area is limited, we can take its benefit only within 

the area range of Wi-Fi. For a Wi-Fi connection, an adapter is made into a 

hotspot, which is usually a wireless router and is connected to other devices 

such as laptops, mobiles, game consoles or PCs to provide internet access. 

2. E-Commerce: Electronic commerce is a way of doing business over the 

Internet. Under e-commerce, the buying or selling of goods or services 

takes place over the Internet. In this, two or more parties exchange data or 

money electronically. 

3. GPS Technology: GPS stands for Global Positioning System. Today, a GPS 

is available in every smartphone. GPS is used to find the geographical 

location of any place. It is a global navigation satellite system. With its help, 

we can find the distance or route between any two places. It is also used to 

find nearby institutions, hotels, offices, etc. or to prepare maps. 

4. Android Technology: Android is an operating system that is used for 

mobiles. It was developed by the Open Handset Alliance and later 

supported by Google. Later it started being used for touch screen devices, 

cell phones and tablets. Android has proven to be a very good platform. Its 

features make it better than other platforms. 
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Expert System 

 
 

 

 

 

 

 

 

Block Diagram of EXPERT SYSTEM 
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Que:15 What is Expert System? Explain its various components. 

Ans: Expert systems are developed using the technology called artificial 

intelligence, which has specialized knowledge about a specific field, subject or 

skill. In fact, it is a computer program that converts the knowledge of an expert 

into a software. Expert systems are developed to find solutions to complex 

problems in a specific field. 

An expert system is a decision-making software. It collects the knowledge of 

various field experts and helps in making decisions and gives feedback with the 

help of it. The knowledge that is collected from field experts is called 

knowledgebase. Expert system is a good example of knowledge-based system. 

Some examples of expert system are as follows- 

• DENDRAL: This is an expert system for chemical analysis. 

• MYCIN: This expert system specializes in the treatment of blood infections. 

• CADET: This expert system is helpful in detecting early types of cancer. 

• PXEDS: This is used to know the stage of lung cancer. 

COMPONENT OF EXPERT SYSTEM: 

The Expert System consists of the following components: 

1. User Interface: It acts as an interface between the user and the inference 

engine. This part receives the question from the user and then sends it to 

the inference engine; after getting the result/answer, it sends the answer to 

the user. 

2. Inference Engine: This is the main part of the expert system. It generates 

the result based on the rules and facts from its knowledge base to the user's 

questions and gives an unbiased answer. It is also called the brain of the 

expert system. 

3. Knowledge Base: This is the part of the expert system where the knowledge 

obtained from the experts is stored. The inference engine examines the data 

based on the facts from the knowledge of this part and then arrives at the 

result. 
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Que:16 What is DigiLocker? Write the steps for using it. 

Ans: DigiLocker is a secure way to store and manage all our important 

documents online, just like NAD (National Academic Depository). Indian citizens 

who register for this online facility are provided with a unique DigiLocker 

account which is linked to the Aadhaar number of the concerned individual. In 

this account, the concerned individual is provided with 1GB of cloud storage. 

National Academic Depository can store only educational qualification 

documents, whereas other documents like Aadhaar card, driving license etc. can 

also be stored in DigiLocker.        

Steps for using DigiLocker: 

i. Open the website https://digilocker.gov.in or install the DigiLocker app 

from Play store on our smartphone. Now, create user ID through OTP (One 

Time Password) using Aadhaar number and Aadhaar linked mobile 

number. 

ii. If any of our e-documents have been issued by any organization, we can 

view it in our DigiLocker. We can also upload our documents ourselves and 

e-sign them. 

iii. We can share the documents by sharing the link of the documents in our 

DigiLocker with others. 
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Cropping a Picture 
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Que:17 Describe the crop settings in the GIMP image editing software. 

Ans: Cropping an image means removing the unwanted parts of the image from 

the corners. To use this tool: 

• Click on TOOLS → TRANSFORM TOOLS → CROP or  

• Click on the CROP tool from the toolbox or  

• Use the SHIFT+C shortcut key. 

When we use this option, a box will appear on the image, with four squares 

formed in its four corners. We can reduce or increase the cropping area using 

these boxes. After setting the correct area, press the Enter key on the keyboard. 

The image will be cropped. 
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Rotating Picture 
 

 

 

 

 

 

 

 

 

 

Flipping the Picture 
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Que:18 Describe the rotate and flip settings in the GIMP image editing 

software. 

Ans: Information about rotating and flipping an image is given below: 

Rotate the Image: 

Rotate tool is used to rotate the image to a specific angle. To use it, click on 

TOOLS → TRANSFORM TOOLS → ROTATE or click on the Rotate tool icon in the 

toolbox, which will select this tool, now click on the image or use the SHIFT+R 

shortcut. 

To rotate the image, use the slider or we can also directly enter the value of the 

angle. If we want to change the position of the image, then we can enter the 

value in Center X and Center Y. Finally, click on the Rotate button. 

If we want to bring the image to its original form, i.e., want to undo the changes 

we have made, then click on the Reset button. 

Flip the image: 

Flip means changing the side of an image. This tool can flip the image vertically 

or horizontally or both. To use it, click on TOOLS → TRANSFORM TOOLS → FLIP 

or click on the Flip tool icon in the toolbox which will select this tool. Now click 

on the image and flip it. 

  



Page | 39  

Vikas Kansal, CF, GSSS (Girls) Sunam, Sangrur (http://cspunjab.nirmancampus.co.in/) 

 

Cut/Split Video Files with the Help of Free Video Cutter Joiner 
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Que:19 Write the steps to cut/split video files with the help of Free Video Cutter 

Joiner. 

Ans: The steps to cut/split video files with the help of Free Video Cutter Joiner are as 

follows: 

Step 1 - Adding Files: Use the Add Video File button to add files to the software. 

After adding the video with the Add Video File button, the preview of the added file 

can be seen inside the application. 

Step 2 - Setting Start Point and End Point: Drag the button on the progress bar 

to set the Start and End Point of the video and then click on the [ (Left Square 

Bracket) button to set the Start Point and click on ] (Right Square Bracket) to set the 

End Point of the video for splitting. 

Step 3 - Cutting/Splitting the Video File: After setting the Start Point and End 

Point of the file for video splitting, click on the "Cut" button. A dialog box will appear 

as shown in the image, from which select the options as required. If the video file 

created after cutting with the option “1. Direct Cut” is not playing properly, then use 

the option “2. Indirect Cut”. 
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 Join/Merge Video Files with the Help of Free Video Cutter Joiner   
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Que:20 Write the steps to join/merge video files with the help of Free Video Cutter 

Joiner. 

Ans: To join/merge videos with the help of Free Video Cutter Joiner software, first select 

the Video Joiner tab by clicking on it, as shown in the image. 

Step 1 - Adding or removing files: Import multiple files at once by clicking on the 

Add File button. If any file is added by mistake, select that file first and then click on 

the Remove button. The file will be removed. 

Step 2 - Merging video files: After selecting the files to be merged, click on the 

“Join” button. A dialog box will open as shown in the image, in which we can select 

different settings according to our requirement. Click on the Start Join button to 

join/merge the videos. 

 

Output file settings: 

By clicking on the Browse button, select the output location and then type the file name 

that we want to set for the video file that will be created after merging. After merging 

the videos, the file will be saved on the selected output folder/location. 

 


